android
  #981  
Old 10-25-2012, 08:07 AM
lebellium's Avatar
lebellium lebellium is offline
Samsung Moderator
 
Join Date: Sep 2007
Location: Paris
Posts: 3,597
Default

In LightROM all Samsung modules have been removed and USB connection doesn't work yet with Rockbox so Safe Mode is the only way to get it recognized by the PC. If you want the usual Samsung USB connection, please come back to fw 2.51.
That was explained in the LighROM read-me file

NEOGHOST is the hidden-memory containing settings and various resources. Read the read-me file of modded fw 2.20 for more info about it.
__________________
I'm French^^ *GenerationMP3 Samsung Moderator*
Reply With Quote

Advertisement [Remove Advertisement]

  #982  
Old 10-25-2012, 08:52 AM
saxonwolfcock saxonwolfcock is offline
Junior Member
 
Join Date: Sep 2012
Posts: 6
Default

Quote:
Originally Posted by lebellium View Post
In LightROM all Samsung modules have been removed and USB connection doesn't work yet with Rockbox so Safe Mode is the only way to get it recognized by the PC. If you want the usual Samsung USB connection, please come back to fw 2.51.
That was explained in the LighROM read-me file

NEOGHOST is the hidden-memory containing settings and various resources. Read the read-me file of modded fw 2.20 for more info about it.
Ah ok. I understand. Quick question then...how do I change the config file to re-enable Safe Mode if the R0 is booting Rockbox and not being recognised by the PC when the USB is plugged in??
Reply With Quote

  #983  
Old 10-25-2012, 09:22 AM
lebellium's Avatar
lebellium lebellium is offline
Samsung Moderator
 
Join Date: Sep 2007
Location: Paris
Posts: 3,597
Default

Press and hold the "back" key during startup, it should connect in Safe Mode.
Alternatively you can modify the file directly from Rockbox (Select the file in File Browser then open the cfg file with the text editor plugin)
__________________
I'm French^^ *GenerationMP3 Samsung Moderator*
Reply With Quote

  #984  
Old 10-25-2012, 10:08 AM
VanniX VanniX is offline
Member
 
Join Date: Nov 2011
Location: Italy - Clowns country
Posts: 120
Default

You can also delete or rename the cfg file from file manager (in rockbox). Player will start with default settings from the next startup ;-)
Reply With Quote

  #985  
Old 10-25-2012, 10:33 AM
saxonwolfcock saxonwolfcock is offline
Junior Member
 
Join Date: Sep 2012
Posts: 6
Default

Thank you! I have reverted back to 2.51 for now, may re-revert to 4.4 once I've had time to read through all the info
Reply With Quote

  #986  
Old 10-25-2012, 12:06 PM
fireandfuel fireandfuel is offline
Junior Member
 
Join Date: Sep 2011
Location: Germany, Berlin
Posts: 15
Default

Quote:
Originally Posted by VanniX View Post
I can't reproduce the "rb hangs" with your methods
Where are your audio files? mmc or internal memory? Does it appen with all tracks(mp3, wma, flac, ecc..)?
Internal memory, I use primary ogg/vorbis (quality setting 8) files and some flac files. I have no mp3 and wma files on my R0.
Found this hang only at ogg/vorbis files.

After one of the 2 hangs at ogg/vorbis files happened there is another bug: The player doesn't start to play tracks on other folders, tested with mp3, ogg/vorbis and flac files.

EDIT: Database was not created/updated or corrupted. I forced rb to recreate the db. rb is now more stable.

Last edited by fireandfuel; 10-25-2012 at 12:46 PM.
Reply With Quote

  #987  
Old 10-25-2012, 02:58 PM
Appick's Avatar
Appick Appick is offline
Junior Member
 
Join Date: Mar 2011
Location: France
Posts: 83
Default

I was wondering if it is necessary to keep the folder OLD_NEOGHOST?
I've just tried the radio - really impressed by the quality. I don't use it often (I would if I could get FIP (not available on FM in my region) - you should try it on the internet radio great variety of music no songs repeated in the same day) but I get the impression that it didn't sound so good before.
RDS seems to work well. I say seems because I couldn't get any complicated convoluted song titles to display with loads of accents - because I couldn't find any radios displaying song titles save one that was playing a Tina Arena track. I use Lebellium's theme and the text in the middle of the screen shows up on a back ribbon. I don't know if this is a known issue. I read some things about RDS further up but can't remember if that was mentioned.
__________________
Appick

Last edited by Appick; 10-26-2012 at 03:47 PM. Reason: Clarity
Reply With Quote

  #988  
Old 10-25-2012, 03:20 PM
lebellium's Avatar
lebellium lebellium is offline
Samsung Moderator
 
Join Date: Sep 2007
Location: Paris
Posts: 3,597
Default

You can delete OLD_NEOGHOST without any problem. It's just a backup for people who had particular files (custom sysdata etc) in Neo-Ghost.

Do you use the v1.60 beta2 of my theme? If yes, there is nothing more you can do. We can only wait for a dev to identify the RDS issues and fix them. And it seems no one is working on that for the moment...
__________________
I'm French^^ *GenerationMP3 Samsung Moderator*
Reply With Quote

  #989  
Old 10-26-2012, 03:54 PM
Appick's Avatar
Appick Appick is offline
Junior Member
 
Join Date: Mar 2011
Location: France
Posts: 83
Default

Quote:
Originally Posted by lebellium View Post
Do you use the v1.60 beta2 of my theme? If yes, there is nothing more you can do. We can only wait for a dev to identify the RDS issues and fix them. And it seems no one is working on that for the moment...
Oops, just discovered it! I'll fix that right away
__________________
Appick
Reply With Quote

  #990  
Old 10-27-2012, 07:33 AM
VanniX VanniX is offline
Member
 
Join Date: Nov 2011
Location: Italy - Clowns country
Posts: 120
Default

Quote:
Originally Posted by fireandfuel View Post
Internal memory, I use primary ogg/vorbis (quality setting 8) files and some flac files. I have no mp3 and wma files on my R0.
Found this hang only at ogg/vorbis files.

After one of the 2 hangs at ogg/vorbis files happened there is another bug: The player doesn't start to play tracks on other folders, tested with mp3, ogg/vorbis and flac files.

EDIT: Database was not created/updated or corrupted. I forced rb to recreate the db. rb is now more stable.
I'm trying with some ogg and flac, but it doesn't hangs. However I have a very small database (with flac and ogg), probably I need to add some track.. when I'll have 5 mins to convert them.
Reply With Quote

  #991  
Old 11-03-2012, 03:07 PM
VanniX VanniX is offline
Member
 
Join Date: Nov 2011
Location: Italy - Clowns country
Posts: 120
Default

For the battery life in LR4.4 there aren't problems in the ROM. The only issue is the charging process without samsung app.
You can test it by:
- Flashing OF v1.25
- Totally discharge the battery
- Totally re-charge the battery
- Re-flash LR4.4

Battery life (tested) is around 24h of continuos playing (with battery bench).

Now i'm trying some power management modifications in kernel/modules.
Reply With Quote

  #992  
Old 11-03-2012, 04:03 PM
Martus0 Martus0 is offline
Junior Member
 
Join Date: Apr 2012
Posts: 51
Default

But after this process the battery starts to charge properly or power modifications in kernel should solve the problem?
Reply With Quote

  #993  
Old 11-03-2012, 04:34 PM
VanniX VanniX is offline
Member
 
Join Date: Nov 2011
Location: Italy - Clowns country
Posts: 120
Default

No, it won't start to charge properly. Actually i don't know for sure why it doesn't charge without official firmware, it's strange because che charging process *should* be an HW process... and not SW.
I also talked with Lorenzo and, although it seems strange, it maybe depends from one of the official app modules.
I think i'll soon release a alpha/beta release to test it.
Reply With Quote

  #994  
Old 11-03-2012, 05:19 PM
Appick's Avatar
Appick Appick is offline
Junior Member
 
Join Date: Mar 2011
Location: France
Posts: 83
Default

I seem to remember a loooong time ago when I first used RB the time synchronising with the computer. After the change in the time last weekend I had to set the time (for the first time ever.) Is this abnormal or is my memory playing tricks? I remember setting the time on the OFW but not on RB!
__________________
Appick
Reply With Quote

  #995  
Old 11-03-2012, 07:02 PM
VanniX VanniX is offline
Member
 
Join Date: Nov 2011
Location: Italy - Clowns country
Posts: 120
Default

With the computer?!? R0 has not any network card.. How could it get the time? :P
The time is synchronized with the linux firmware "under" Rockbox. Also in OF there is the time sync, but there are also some strange samsung things about this feature (in fact sometimes there are problems when you use both firmware with Modfirm 2.5).
Reply With Quote

  #996  
Old 11-04-2012, 04:42 AM
Lorenz092 Lorenz092 is offline
Member
 
Join Date: Jan 2011
Location: Italy
Posts: 449
Default

Quote:
Originally Posted by VanniX View Post
With the computer?!? R0 has not any network card.. How could it get the time? :P
The time is synchronized with the linux firmware "under" Rockbox. Also in OF there is the time sync, but there are also some strange samsung things about this feature (in fact sometimes there are problems when you use both firmware with Modfirm 2.5).
Well the problem is that Samsung doesn't read time from the RTC directly, but uses a difference, I did not investigate much on that but now would be nice to do so!
__________________
Check out my modded firmware both for YP-R0 and YP-R1!!!
** DONATE ** -> https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=K658CHJKX2X8C
NOTE: if you want to donate for Rockbox itself and not my work, go to their website!!
Reply With Quote

  #997  
Old 11-04-2012, 05:18 PM
VanniX VanniX is offline
Member
 
Join Date: Nov 2011
Location: Italy - Clowns country
Posts: 120
Default

Quote:
Originally Posted by Lorenz092 View Post
Well the problem is that Samsung doesn't read time from the RTC directly, but uses a difference, I did not investigate much on that but now would be nice to do so!
There is also a service in init.d for the time sync..
However i'm releasing the LR 4.5 (for fix the charging issue). You can find debug release in ROM_List (http://dl.dropbox.com/u/21543264/YP-...eases/ROM_List)
Reply With Quote

  #998  
Old 11-05-2012, 07:08 AM
fireandfuel fireandfuel is offline
Junior Member
 
Join Date: Sep 2011
Location: Germany, Berlin
Posts: 15
Default

Quote:
Originally Posted by VanniX View Post
I'm trying with some ogg and flac, but it doesn't hangs. However I have a very small database (with flac and ogg), probably I need to add some track.. when I'll have 5 mins to convert them.
It's bad that you can't reproduce it.

I have a 640x640 320x320 jpg picture called cover.jpg (I already converted it to non-progressive jpeg, best quality, optimized huffman table, subsampling rate "1x1, 1x1, 1x1") in nearly every music folder.

A typical folder with music looks like this:
Code:
[...]/Music/Amon Amarth/With Oden on Our Side

18.02.2011  07:13         9.836.025 Amon Amarth - 01 - Valhall Awaits Me.ogg
18.02.2011  07:13         9.708.124 Amon Amarth - 02 - Runes to My Memory.ogg
18.02.2011  07:13         6.290.789 Amon Amarth - 03 - Asator.ogg
18.02.2011  07:13         9.465.468 Amon Amarth - 04 - Hermod's Ride to Hel - Lokes Treachery, Part 1.ogg
18.02.2011  07:14        12.203.735 Amon Amarth - 05 - Gods of War Arise.ogg
18.02.2011  07:14         9.483.358 Amon Amarth - 06 - With Oden on Our Side.ogg
18.02.2011  07:14         8.102.964 Amon Amarth - 07 - Cry of the Black Birds.ogg
18.02.2011  07:14         8.296.689 Amon Amarth - 08 - Under the Northern Star.ogg
18.02.2011  07:14        13.883.311 Amon Amarth - 09 - Prediction of Warfare.ogg
05.11.2012  13:57           128.457 cover.jpg
EDIT: I checked the file system for errors and converted the cover.jpg's now down to 320x320.
I hope this reduce hangs a little bit. No it doesn't.

I use a slightly modified version of Acuity theme (http://themes.rockbox.org/index.php?...et=samsungypr0).

EDIT2: Without a cover.jpg the hang happens, too. That's a mysterious bug.

Last edited by fireandfuel; 11-05-2012 at 07:26 AM.
Reply With Quote

  #999  
Old 11-05-2012, 07:17 AM
lebellium's Avatar
lebellium lebellium is offline
Samsung Moderator
 
Join Date: Sep 2007
Location: Paris
Posts: 3,597
Default

I won't encourage illegal music sharing and downloading but for debugging purpose I would advise you to upload some problematic FLAC/OGG files and PM VanniX for the download link

FYI, modded firmware 2.51 has been downloaded 484 times so far and LightRom v4.4 has been downloaded 115 times.


PS: you listen to Amon Amarth and live in Berlin? I guess we should meet each other before I go back to Paris in December
__________________
I'm French^^ *GenerationMP3 Samsung Moderator*
Reply With Quote

  #1000  
Old 11-05-2012, 09:35 AM
VanniX VanniX is offline
Member
 
Join Date: Nov 2011
Location: Italy - Clowns country
Posts: 120
Default

Yep, it should be a good idea if you can send me some "hanging tracks".
I also tried with other ogg in these days, converted manually (from mp3 320kbps) with audacity, but i can't hear anything strange. I notice only a bit longer time in DB init with ogg instead of mp3 (probably depends from file size, tag or something similar).

P.S: Good stats for ROMs download!

P.S2: New LR seems to have not strange battery management bugs.
Fully charged yesterday evening, now is 63% with more than 13 hours of non-continuous playback (3+4+1+3+2+is still playing). I hope to come back to his "loved" 25hrs.
Reply With Quote

Reply

Tags
r0, rockbox, samsung yp-r0

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT -5. The time now is 09:27 PM.