android
  #1  
Old 10-28-2010, 09:14 PM
JayC_783's Avatar
JayC_783 JayC_783 is offline
Junior Member
 
Join Date: May 2010
Location: MI's Thumb
Posts: 27
Default How long have you had your X-Fi2?

I ordered the X-Fi2 (8GB) about a week ago off Amazon. I should have it tomorrow. I have wanted it for a long time and read a lot about it as well as watching videos on YouTube. I know people have had issues with their Zens while reading the forums here and user reviews. I'm just curious how long have you had your X-Fi2 and if it still works good? I don't use my current MP3 player much (Sony Walkman E345), so I won't be using the Zen a lot, either.
Reply With Quote

Advertisement [Remove Advertisement]

  #2  
Old 10-28-2010, 09:48 PM
sYlt's Avatar
sYlt sYlt is offline
Member
 
Join Date: Feb 2010
Location: Lisbon, Portugal
Posts: 291
Default

I think I've had mine since the end of September from last year, so it kinda makes it 1 year & 1 month. Quite happy with it and I doubt there is anything that will make me change my mind.

When you get yours just make sure you update it with the last firmware and enjoy what this player has to offer!
Reply With Quote

  #3  
Old 10-29-2010, 12:57 AM
Habhome's Avatar
Habhome Habhome is offline
Moderator
 
Join Date: Jan 2010
Location: Sweden
Posts: 1,079
Default

I bought mine on the 25th of December IIRC, so it'll soon be a year. It's still working good. Though I recently stopped my everyday use of it and started to use my cellphone while biking to and from school, too many missed calls =P
__________________
"If you are good enough at English to apologize, then there is no need to." - A good friend of mine
Discovered something about the X-Fi2 you think others may not know? Post it here so others can learn about it!
Have a question about X-Fi2 apps? Consult the FAQ before creating a thread about it.
Like my work? Tell your friends. Don't like it? Tell me so I can improve. ^.^
Reply With Quote

  #4  
Old 10-29-2010, 06:29 AM
ZaPx64's Avatar
ZaPx64 ZaPx64 is offline
Member
 
Join Date: Nov 2009
Location: Germany
Posts: 136
Default

Mine's a bit older than one year, still works excellent.
__________________
Zen X-Fi2 Apps: Notee-fi (notepad) | TicTacToe | Mahjongg
http://www.starfare.eu/ - a free real-time strategy game.
Reply With Quote

  #5  
Old 10-29-2010, 09:10 AM
skybluedream skybluedream is offline
Member
 
Join Date: Oct 2009
Posts: 132
Default

I had it for 3 weeks & put it on ebay & sold it.

It was my second Creative Player after the Vision:M was extremely disappointed & that was that.

Not saying that X-Fi2 is crap to me it just seemed like it lol & no where near the Vision:M. I guess touchscreen one's aren't for me.
Reply With Quote

  #6  
Old 10-29-2010, 02:53 PM
datallboy's Avatar
datallboy datallboy is offline
Member
 
Join Date: Feb 2010
Posts: 143
Default

got mine last christmas
__________________
I wUz he3R
Reply With Quote

  #7  
Old 10-29-2010, 03:17 PM
Brett_val's Avatar
Brett_val Brett_val is offline
Senior Member
 
Join Date: Jan 2010
Location: The Netherlands
Posts: 636
Default

I bought mine in January this year. I don't use it every day but I've never had problems with it and it's still working as it should.

Only thing is that the rubber tips on the headphones (ep 630) cracked so I bought some new tips for it.
__________________
this is a link to my personal homepage which I haven't
Reply With Quote

  #8  
Old 10-29-2010, 06:51 PM
LacusClyne LacusClyne is offline
Junior Member
 
Join Date: Jul 2010
Posts: 2
Default

Had mine since december last year, 16gb model though...so far it's still serving me well..gotta love my X-fi2 ...
Reply With Quote

  #9  
Old 10-29-2010, 10:23 PM
jbob182's Avatar
jbob182 jbob182 is offline
X-Fi2 Development Moderator
 
Join Date: Feb 2010
Location: The U.S.A.
Posts: 554
Default

I got mine last December. The only problem i had was with the earbuds the right ear shorted out after 6months or so. Other than that i have had no problems.
Reply With Quote

  #10  
Old 10-31-2010, 12:57 AM
JD_THEBEST's Avatar
JD_THEBEST JD_THEBEST is offline
Junior Member
 
Join Date: Apr 2010
Location: Wentworth, Australia
Posts: 18
Default

I got mine on my birthday April 10 and it broke after 6 days (screen bruise) send it back and it took 2 months to get back (it was a brand new one) and it got bruises again this time i have 4 bruises but i cbf sending it back =(
Reply With Quote

  #11  
Old 10-31-2010, 08:52 AM
jbob182's Avatar
jbob182 jbob182 is offline
X-Fi2 Development Moderator
 
Join Date: Feb 2010
Location: The U.S.A.
Posts: 554
Default

you were probably touching the screen to hard i know i got one when i pressed really hard
Reply With Quote

  #12  
Old 10-31-2010, 01:15 PM
jammaniaclord jammaniaclord is offline
Junior Member
 
Join Date: Jun 2010
Posts: 61
Default

I've had mine since May 2010. To say i have thoroughly enjoyed it, would be 85% true.

The Vision:M was probably their best player evah, and all players since have been judged to that standard. Granted the Zen was bulky, it was solid for the most part (still have mine and it works flawlessly), the Zen X-Fi 2 is pretty nice. It needs some major firmware improvements, yet it does suffice as it stands. Centrale needs a major overhaul. FLAC album art should work within Centrale. My biggest complaint was that it took 3 months for customer service to send me another unit, when the last firmware killed my player. Customer service sucks ass. Anytime an upgrade comes out now, i am afraid to install it.

If anything happens again to this player, i am switching to Sony, or Phillips, or whoever else has a decent PMP.
Reply With Quote

  #13  
Old 02-07-2011, 06:28 AM
samoht93 samoht93 is offline
Junior Member
 
Join Date: Feb 2011
Posts: 1
Default

I got it since January 2010. Very happy with it, only problem I had is that the right side of the included in ear phones stoped working. That was after 8 or 9 months I think. (All my headphones break after like 6 months).
Reply With Quote

  #14  
Old 02-08-2011, 02:05 AM
EsEm EsEm is offline
Junior Member
 
Join Date: Jul 2006
Posts: 64
Default

Had one for about 6 months now and I am now giving up with it and going back to using my Zen.

The touch screen is appalling, trying to change the volume level this morning and couldn't get it set to 12.

__________________
Current Collection: Sony: NWZ-A866, NWZ-A845, NWZ-X1060 Creative: ZEN(32GB), Zen Vision, Zen Micro, Zen NX, Muvo2 Sandisk: Sansa e280, Clip, Clip+, Fuze+ Rio: Carbon iRiver: T60 iPod: Nano, Shuffle Shure: SE530, SE420 SE210 & E3C.
Reply With Quote

  #15  
Old 02-17-2011, 06:51 AM
robgmun robgmun is offline
Junior Member
 
Join Date: Jul 2010
Posts: 19
Default

About 1 year now and i hate it, and unless Creative release a Mp3 player with a lovely responsive touch screen this will be the last Creative i will ever buy. I'm eye'ing up the Cowon J3 32Gb
Reply With Quote

  #16  
Old 02-17-2011, 08:00 AM
JayC_783's Avatar
JayC_783 JayC_783 is offline
Junior Member
 
Join Date: May 2010
Location: MI's Thumb
Posts: 27
Default

I guess the interface of this thing really is subjective. I've had absolutely no issues with the interface thus far. I am running the latest firmware. When I got it back in October it came with an updated firmware already installed (1.12.something). Since it came with an updated firmware on it I never did get to see what it was like with the original firmware. For a resistive touch screen the X-Fi2 really isn't all that bad.
Reply With Quote

  #17  
Old 02-19-2011, 09:39 AM
robgmun robgmun is offline
Junior Member
 
Join Date: Jul 2010
Posts: 19
Default

I've got the latest firmware too and unless you press down really hard then nothing happens, and even if you do press down hard, sometimes nothing still happens.
Reply With Quote

  #18  
Old 02-19-2011, 04:19 PM
JayC_783's Avatar
JayC_783 JayC_783 is offline
Junior Member
 
Join Date: May 2010
Location: MI's Thumb
Posts: 27
Default

Quote:
Originally Posted by robgmun View Post
I've got the latest firmware too and unless you press down really hard then nothing happens, and even if you do press down hard, sometimes nothing still happens.
Really? Wow. I can barely just touch mine and it works. I wonder if yours is faulty? If I give mine anything more than just the lightest of touches I'm afraid I'll bruise the screen.
Reply With Quote

  #19  
Old 03-21-2011, 12:11 PM
robgmun robgmun is offline
Junior Member
 
Join Date: Jul 2010
Posts: 19
Default

Quote:
Originally Posted by JayC_783 View Post
Really? Wow. I can barely just touch mine and it works. I wonder if yours is faulty? If I give mine anything more than just the lightest of touches I'm afraid I'll bruise the screen.
I almost find that hard to believe considering the techology behind it, it's not a capacitive screen you know.
Reply With Quote

  #20  
Old 03-21-2011, 02:25 PM
Brett_val's Avatar
Brett_val Brett_val is offline
Senior Member
 
Join Date: Jan 2010
Location: The Netherlands
Posts: 636
Default

Quote:
Originally Posted by robgmun View Post
I almost find that hard to believe considering the techology behind it, it's not a capacitive screen you know.
Being a resistive touchscreen means you have to press it, but really not hard. It should register a touch with the lightest press. A stylus or fingernail works best but a thumb-press or other less accurate pressing also works fine, although then it can unintentionally scroll - which is the "getting used to"-part of resistive touchscreens.
__________________
this is a link to my personal homepage which I haven't
Reply With Quote

Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT -5. The time now is 08:57 AM.