android
  #1  
Old 10-21-2011, 04:34 PM
CiaranTurner CiaranTurner is offline
Junior Member
 
Join Date: Oct 2011
Posts: 1
Default Cannot turn on/power up my X-Fi2

Hey, a while back my X-Fi2 wouldnt turn off unless i hit the reset button, and then after i turned it off i couldn't turn it back on, so far i have tried all USB slots in my computer, the computer doesnt recognize anything has been plugged in and the X-Fi2 stays with a blank screen.

Getting it to work is not my #1 priority at the moment, i got a new computer and my X-Fi2 has all my music on and i wonder how i can obtain it again? (i did not use the external Micro SD card slot).

Any suggestions or tips? i have checked other forums and the creative website with no luck currently.
Reply With Quote

Advertisement [Remove Advertisement]

  #2  
Old 10-23-2011, 10:21 AM
flashpoint_1230 flashpoint_1230 is offline
Junior Member
 
Join Date: Jan 2010
Location: Indiana
Posts: 15
Default

This happened to me... I wonder if it is a hardware error. I've had my X-Fi2 for a few years, but back in February or so, it started to act weirdly. It would freeze and/or not let me turn it off without resetting. It also displayed the same symptoms as yours when trying to connect it to a computer.

I just accepted that it was bricked, seeing as how nothing has seemed to fix it. I wish I'd taken the time to grab my music off of it, though.

I'm pretty sure it's a hardware error... Time to go shop for a new PMP!
Reply With Quote

  #3  
Old 10-24-2011, 06:26 AM
jammaniaclord jammaniaclord is offline
Junior Member
 
Join Date: Jun 2010
Posts: 61
Default

Sorry to hear that. i had an issue last year while upgrading the firmware on my 64GB model, and it finally bricked itself. I had to RMA it, and it was a NIGHTMARE dealing with Creative. I finally got it back after 3 months of pestering them, and it still works, but i do not trust the player anymore, and sometimes after i load new music on it, it seems like it takes forever for the "rebuilding library" screen to come up, and once or twice I have had it lock up on the "ZEN" screen, and had to push the reset button, and cross my fingers it would power up. Creative's quality has gone downhill on these players.

Good luck on getting resolve on your issue. It sounds like you may have to return it for a replacement, and if it is under warranty still, then that is cool. If not, it might be better to just buy another vendors PMP. Zen Vision:M was the last kick ass player they made IMHO.
Reply With Quote

Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT -5. The time now is 07:13 PM.