android
  #1  
Old 03-17-2011, 05:12 PM
rEUD0yNGneUGi9n rEUD0yNGneUGi9n is offline
Junior Member
 
Join Date: Jul 2010
Posts: 31
Default Does anyone have 3.8 with the USB patch?

Does anyone have a Rockbox 3.8 build for the Clip+ with the USB patch?

Thanks.

Last edited by rEUD0yNGneUGi9n; 03-17-2011 at 09:59 PM.
Reply With Quote

Advertisement [Remove Advertisement]

  #2  
Old 03-18-2011, 03:24 PM
Pennhaven Pennhaven is offline
Member
 
Join Date: Dec 2006
Location: Michigan
Posts: 205
Default

Provided the post 3.8 SVN is now stable we can hope that dfkt will find time to compile another build with the USB and Meier cross feed patches.

Maybe if we all say "please".

Last edited by Pennhaven; 03-18-2011 at 03:32 PM.
Reply With Quote

  #3  
Old 03-18-2011, 04:08 PM
Astral_Milk Astral_Milk is offline
Junior Member
 
Join Date: Mar 2011
Posts: 4
Default

Please.
Reply With Quote

  #4  
Old 03-18-2011, 04:52 PM
dfkt's Avatar
dfkt dfkt is offline
Moderator
 
Join Date: May 2006
Location: Vienna, Austria
Posts: 15,330
Default

The USB patch is out of sync, it will not apply to newer revisions. Nothing I can do about it, that needs some seriously deep understanding of the Rockbox source code, of USB transfer, and so on.

Also, 3.8 is a forked stable release, outside of SVN. It's not an ongoing revision - you can't take that code and still call it "3.8 release" after you apply some patches to it. This is something completely different to applying patches to SVN.
__________________
Please don't PM me with questions that can be answered in a forum thread. Don't be an idiot.
My Gear and Reviews | My RMAA Tests | IRC: #anythingbutipod on Freenode | Last.fm | Album Art Exchange | Rockbox | Replaygain
Reply With Quote

  #5  
Old 03-18-2011, 07:25 PM
Pennhaven Pennhaven is offline
Member
 
Join Date: Dec 2006
Location: Michigan
Posts: 205
Default

Oh well, thanks anyway. Your previous builds are working fine for my needs.
Reply With Quote

  #6  
Old 03-18-2011, 08:10 PM
marc2003's Avatar
marc2003 marc2003 is offline
Member
 
Join Date: Jul 2008
Location: England
Posts: 297
Default

Quote:
Originally Posted by dfkt View Post
The USB patch is out of sync, it will not apply to newer revisions.
it was still working for me a couple of days back?? i can't test against latest SVN right now though.

edit: how embarrassing. i just checked the date and it was infact 12 days ago. still well after 3.8 was released but not nearly as recent as i thought. where does the time go.
__________________
Sansa Clip+ 8GB :: Sandisk 16GB Micro SDHC :: Rockbox :: FiiO E6 :: Sennheiser PX100 II

Last edited by marc2003; 03-18-2011 at 08:31 PM.
Reply With Quote

  #7  
Old 03-20-2011, 11:06 AM
funman funman is offline
Rockbox Developer
 
Join Date: Jul 2008
Posts: 161
Default

Just uncomment #define USE_ROCKBOX_USB in firmware/export/config/sansaclipplus.h and it should "work"
Reply With Quote

  #8  
Old 03-21-2011, 04:35 PM
ted209 ted209 is offline
Junior Member
 
Join Date: Dec 2008
Posts: 39
Default

Here's a build I made yesterday. It contains the following patches:

FS#9305 - Context sensitive backlight on key press (updated to work with radio)
FS#11304 - higher quality audio hw settings for AS3543
FS#11767 - Meier crossfeed V3

Plus:
USB enabled (as described by Funman above):
"uncomment #define USE_ROCKBOX_USB in firmware/export/config/sansaclipplus.h"
Button mapping:
Long-press home (was Quickscreen) is now the "WPS Hotkey".
Home+power is now Quickscreen
Database view:
Removed <All tracks> and <Random> items from database.

This version does NOT include the very latest SD patches in the SVN:

r29624: SD amsv2: remove double assignement

r29625: SD AMSv2: fix r29169

Restore access to the last AMS_OF_SIZE == 0xF000 sectors of internal drive
Mostly visible when using USB (or database?)

r29627: AMSv2 SD: use a sleep instead of a udelay for 100 ms delay

I made a compile with these included, and my 16gb PNG SD card no longer works with it. I have tested it quickly, and all seems fine. Enjoy!

http://www.mediafire.com/?q1dbossawfg343b

PS. There's active development on SD card access (new patch just after I posted "r29628: AMSv2 SD: wait for previous data transfer completion before sending a command"). I'll make another build soon and see if SD card access is working again.

Last edited by ted209; 03-21-2011 at 04:45 PM.
Reply With Quote

  #9  
Old 03-21-2011, 04:44 PM
saratoga saratoga is offline
Rockbox Developer / Moderator
 
Join Date: Apr 2007
Posts: 3,586
Default

Does anyone actually have a player where FS#11304 solves some problem? I don't mind committing that if someone could show it actually does something. At least on my hardware it literally does nothing at all.
__________________
Interested in Google's Summer of Code ? PM me.
Reply With Quote

  #10  
Old 03-21-2011, 04:51 PM
ted209 ted209 is offline
Junior Member
 
Join Date: Dec 2008
Posts: 39
Default

Quote:
Originally Posted by saratoga View Post
Does anyone actually have a player where FS#11304 solves some problem? I don't mind committing that if someone could show it actually does something. At least on my hardware it literally does nothing at all.
Haha, yes it's my understanding that it has no proven positive or negative effect on output. I had no rational reason for including it!
Reply With Quote

  #11  
Old 03-21-2011, 07:08 PM
marc2003's Avatar
marc2003 marc2003 is offline
Member
 
Join Date: Jul 2008
Location: England
Posts: 297
Default

Quote:
Originally Posted by funman View Post
Just uncomment #define USE_ROCKBOX_USB in firmware/export/config/sansaclipplus.h and it should "work"
i tried this on my clip v2 (editing sansaclipv2.h, obviously) against latest SVN and it doesn't appear to fully work. it seems to be fine in ubuntu 10.10 but my windows 7 isn't recognising it properly. no errors - just the "safely remove" icon appears but nothing in explorer. if i try and open disk management or device manager, the window just hangs.

is anybody else with a clipv2 having any joy?
__________________
Sansa Clip+ 8GB :: Sandisk 16GB Micro SDHC :: Rockbox :: FiiO E6 :: Sennheiser PX100 II
Reply With Quote

  #12  
Old 03-21-2011, 07:47 PM
saratoga saratoga is offline
Rockbox Developer / Moderator
 
Join Date: Apr 2007
Posts: 3,586
Default

Quote:
Originally Posted by marc2003 View Post
i tried this on my clip v2 (editing sansaclipv2.h, obviously) against latest SVN and it doesn't appear to fully work. it seems to be fine in ubuntu 10.10 but my windows 7 isn't recognising it properly. no errors - just the "safely remove" icon appears but nothing in explorer. if i try and open disk management or device manager, the window just hangs.
And now you know why its disabled by default
__________________
Interested in Google's Summer of Code ? PM me.
Reply With Quote

  #13  
Old 03-21-2011, 07:50 PM
marc2003's Avatar
marc2003 marc2003 is offline
Member
 
Join Date: Jul 2008
Location: England
Posts: 297
Default

well i wasn't asking for it to be enabled by default.

besides, i've manually synced the original patch from flyspray to current SVN and that's working so i'm happy.
__________________
Sansa Clip+ 8GB :: Sandisk 16GB Micro SDHC :: Rockbox :: FiiO E6 :: Sennheiser PX100 II
Reply With Quote

  #14  
Old 03-22-2011, 12:28 PM
telliott telliott is offline
Junior Member
 
Join Date: Feb 2008
Posts: 39
Default

Quote:
Originally Posted by marc2003 View Post
well i wasn't asking for it to be enabled by default.

besides, i've manually synced the original patch from flyspray to current SVN and that's working so i'm happy.
Could you provide us less technical people with your build?

Thanks
Reply With Quote

  #15  
Old 03-22-2011, 03:18 PM
marc2003's Avatar
marc2003 marc2003 is offline
Member
 
Join Date: Jul 2008
Location: England
Posts: 297
Default

ok here you go, my build for the clip v2.

http://cid-649d3bfeaf541fbb.office.l...clipv2-usb.zip
__________________
Sansa Clip+ 8GB :: Sandisk 16GB Micro SDHC :: Rockbox :: FiiO E6 :: Sennheiser PX100 II
Reply With Quote

  #16  
Old 03-22-2011, 05:21 PM
telliott telliott is offline
Junior Member
 
Join Date: Feb 2008
Posts: 39
Default

Quote:
Originally Posted by marc2003 View Post
ok here you go, my build for the clip v2.

http://cid-649d3bfeaf541fbb.office.l...clipv2-usb.zip
Thanks but I have a clip+ I guess I should have specified.
Reply With Quote

  #17  
Old 03-22-2011, 05:55 PM
marc2003's Avatar
marc2003 marc2003 is offline
Member
 
Join Date: Jul 2008
Location: England
Posts: 297
Default

i assumed you had a clip v2 because my post was quite specific about creating a v2 build for myself.

edit: clip plus build removed - it doesn't work.
__________________
Sansa Clip+ 8GB :: Sandisk 16GB Micro SDHC :: Rockbox :: FiiO E6 :: Sennheiser PX100 II

Last edited by marc2003; 03-22-2011 at 08:42 PM.
Reply With Quote

  #18  
Old 03-22-2011, 08:27 PM
telliott telliott is offline
Junior Member
 
Join Date: Feb 2008
Posts: 39
Default

No luck. Rockbox detects the USB plug but the computer (Windows 7) doesn't.

Thanks anyway
Reply With Quote

  #19  
Old 03-22-2011, 08:42 PM
marc2003's Avatar
marc2003 marc2003 is offline
Member
 
Join Date: Jul 2008
Location: England
Posts: 297
Default

oh well, nowt i can do about that. i'll take the link down to save anybody else wasting their time with it.
__________________
Sansa Clip+ 8GB :: Sandisk 16GB Micro SDHC :: Rockbox :: FiiO E6 :: Sennheiser PX100 II
Reply With Quote

  #20  
Old 03-22-2011, 08:58 PM
marc2003's Avatar
marc2003 marc2003 is offline
Member
 
Join Date: Jul 2008
Location: England
Posts: 297
Default

can you try another clip+ usb build? this time it's using the simpler method funman mentioned above that doesn't work on my v2.

http://cid-649d3bfeaf541fbb.office.l...p-plus-usb.zip
__________________
Sansa Clip+ 8GB :: Sandisk 16GB Micro SDHC :: Rockbox :: FiiO E6 :: Sennheiser PX100 II
Reply With Quote

Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT -5. The time now is 01:29 AM.