android
  #1  
Old 05-22-2011, 11:02 AM
Smithers475 Smithers475 is offline
Junior Member
 
Join Date: May 2011
Posts: 2
Default No Power or Anything

Hey everyone, I have an old 20GB Zen, which last time i got out worked, I just got it out again then to see if it had some of my missing songs on it and all i could get it to do was show the splash screen and it would go off again, the computer recognized it once, the battery icon was on and flashing while it was plugged in. After about 5 - 10 mins, absolutely nothing was working, no charging, screen wouldnt turn on at all, no light, no power at all, computer wont recognise it even plugged in, computer wouldnt even detect that it was plugged in at all, ive tried holding the power switch in, tried resetting it and still nothing. Does this mean its completely dead or is there something else I can try? Thanks for any help
Reply With Quote

Advertisement [Remove Advertisement]

  #2  
Old 05-22-2011, 11:40 AM
Smithers475 Smithers475 is offline
Junior Member
 
Join Date: May 2011
Posts: 2
Default

Nevermind, it decided to start working again after about the 5th time of holding both the power switch on and the reset button at the same time.
Reply With Quote

Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT -5. The time now is 07:19 AM.