android
  #21  
Old 02-10-2012, 06:53 AM
cbomb cbomb is offline
Junior Member
 
Join Date: Aug 2011
Posts: 38
Default

looks like they realized there was something wrong and chose the easiest way to show us
Reply With Quote

Advertisement [Remove Advertisement]

  #22  
Old 02-10-2012, 09:41 AM
TackyTiger's Avatar
TackyTiger TackyTiger is offline
Member
 
Join Date: Mar 2009
Location: Airstrip One
Posts: 165
Default

They wouldn't have been removed without a long and protracted discussion

I think there's some work going on with checkwps and the switch to git.

Probably best to hold tight and stay cool for a bit.
Reply With Quote

  #23  
Old 02-11-2012, 04:34 PM
eiffel eiffel is offline
Junior Member
 
Join Date: Feb 2012
Posts: 2
Default

Thanks for a great theme (Zyp is my clear favorite - clean look, large track art, etc.).

As a Rockbox newbie, it took me a while to get it to work (I needed version 1.1, and had to install the font pack which wasn't clear to me (which can be found here: http://www.rockbox.org/download/byhand.cgi).

Once configured properly (disabling icons and scroll bars in the settings - theme section), I'm a very happy camper!

Last edited by eiffel; 02-12-2012 at 05:36 PM.
Reply With Quote

  #24  
Old 02-11-2012, 06:39 PM
TCD1975 TCD1975 is offline
Junior Member
 
Join Date: Jan 2010
Posts: 32
Default

I assume you installed the Zyp theme. I'm glad you like it.

I'm trying to get the other two themes (and a fourth theme that I haven't uploaded yet) sorted so that they work with the current build.

I don't think there is a problem with the themes themselves ... there is some standard code (for adding background images to the volume progress bar) that seems to have been broken on the latest Rockbox release, hence several pre-existing and functioning themes are currently listed as not working.

I've reported the bug so hopefully it'll get fixed and the other existing themes will be made available again.
Reply With Quote

  #25  
Old 02-13-2012, 09:59 AM
apurvmj apurvmj is offline
Junior Member
 
Join Date: Dec 2011
Posts: 18
Default

rockbox ver. on which "dfkt min" works with album art; doesn't work with zyp.
Zyp theme takes off with default theme.
btw "stg" theme on my CZ gives smooth backround, but "zyp" theme shows some banding of shades. is it same for you all or is it I'm unlucky.
A video of these theme would be nice
thanks.
Reply With Quote

  #26  
Old 02-13-2012, 07:40 PM
TCD1975 TCD1975 is offline
Junior Member
 
Join Date: Jan 2010
Posts: 32
Default

Yeah, Zyp does have some banding. They all do if you really look at the screen. The banding isn't there in the images I created but I think Rockbox redraws or compresses them in some way ... either that or the Clip Zip screen might have a limited colour pallete.

If you install a version of Rockbox from a week or so ago you should get your album art back ... in theory anyway.

I installed Rockbox on the 7th of feb and I have no problem displaying album art with the themes I've created ... I believe there are some bugs that effect the themes which have only been introduced to Rockbox in the past week.

I'd give the 7th of Feb 5th of Feb build a try (it seems to be the 7th of Feb when things go wrong) ...

http://download.rockbox.org/daily/sansaclipzip/

I hope that Rockbox sorts out these small theme bugs soon ... I've already created another couple of themes I'd like to upload.

Last edited by TCD1975; 02-14-2012 at 06:45 AM.
Reply With Quote

  #27  
Old 02-14-2012, 01:48 PM
kredig's Avatar
kredig kredig is offline
Senior Member
 
Join Date: Feb 2007
Location: Berlin
Posts: 505
Default

the version from feb 5th does not show the album art for me.
do i need to enable the album art somewhere (i received the clip only today and just put rockbox on it)?
Reply With Quote

  #28  
Old 02-14-2012, 02:02 PM
skip252 skip252 is offline
Administrator
 
Join Date: Dec 2007
Location: Chicago
Posts: 5,444
Default

The bug was closed that was causing this problem. I've tried these themes with a current build and they are displaying properly for me now.

There's no need to activate album art display. Just be sure your album art is set according to the guidelines and it should display automatically. I sometimes use embeded AA and sometimes a .jpg named "cover" or "folder" per album folder. Both work for me equally well.
Reply With Quote

  #29  
Old 02-14-2012, 02:17 PM
kredig's Avatar
kredig kredig is offline
Senior Member
 
Join Date: Feb 2007
Location: Berlin
Posts: 505
Default

ah, good to know. thank you.
i'm synching some files right now. i put my mediamonkey settings that it will put the album art in the tag and in the folder. will see if this works.
Reply With Quote

  #30  
Old 02-14-2012, 02:24 PM
TCD1975 TCD1975 is offline
Junior Member
 
Join Date: Jan 2010
Posts: 32
Default

Yay! I got an email today which told me that the issue with the themes has been resolved. I've tried the lates build and things seem okay to me.

I've got a feeling that all of the Clip Zip themes that disappeared the other day will reappear within the next 24 hours (as soon as CheckWPS gets updated). I've also got a couple of new themes that I'll upload as soon as CheckWPS gets updated.

If anyone is still having issue with their album art not displaying I really don't think it's down to the themes. More information about album art for Rockbox can be found here and I'd recommend using AlbumArtExtractor. If you have embedded album art it can copy a small file into that folder which is optimised for Rockbox. I'd recommend exporting out files called cover.bmp resized to 96 x 96. It's worked a treat for me.
Reply With Quote

  #31  
Old 02-15-2012, 07:38 AM
TCD1975 TCD1975 is offline
Junior Member
 
Join Date: Jan 2010
Posts: 32
Default

All the themes are now back online at http://themes.rockbox.org/index.php?target=sansaclipzip and two new themes (Neu & Pro) have been added to the beginning of this thread.

Last edited by TCD1975; 02-15-2012 at 09:28 AM.
Reply With Quote

  #32  
Old 02-15-2012, 08:23 PM
al3rd al3rd is offline
Junior Member
 
Join Date: May 2010
Location: Manila, Philippines
Posts: 59
Thumbs up

Quote:
Originally Posted by TCD1975 View Post
All the themes are now back online at http://themes.rockbox.org/index.php?target=sansaclipzip and two new themes (Neu & Pro) have been added to the beginning of this thread.
Pro, Neu, Blu are my favorite theme i use them on while playing screen btw i love how you put a volume knob that's a big thumbs up
Reply With Quote

  #33  
Old 02-17-2012, 10:15 AM
apurvmj apurvmj is offline
Junior Member
 
Join Date: Dec 2011
Posts: 18
Default

even with latest RB version and resized 96*96 embedded album art 'neu' theme isn't still working for me. I mean all setup works like default theme.
Kindly upload video of working theme.
thanks
Reply With Quote

  #34  
Old 02-17-2012, 12:08 PM
skip252 skip252 is offline
Administrator
 
Join Date: Dec 2007
Location: Chicago
Posts: 5,444
Default

Someone might upload a video but I can't see how that would help you troubleshoot your problem. I just tried all the themes from the site, not just the ones from TCD1975, using build a794aaa-120217. They all work for me. I usually use a cover or .jpg file per folder but I embedded some images to check if that might be an issue and the AA works reliably for me either way.

You may want to reset all your theme settings by finding and deleting the config.cfg file from your .rockbox folder. That's what I did after the fix that got the themes working again. That will reset all your settings to the defaults so if you have any custom EQ or other settings you'll want to back those up to presets.

I can't see a reason to resize your album art to 96x96. I use 500x500 baseline .jpgs on all my Rockboxed players. The size is under under 75 kb usually. At that quality they display nicely on the player and fairly well on my PC monitor. They're nice and sharp on my Fuze and e250. They do about as well as can be expected on the lower quality screen of the Clip Zip.
Reply With Quote

  #35  
Old 02-17-2012, 01:01 PM
TCD1975 TCD1975 is offline
Junior Member
 
Join Date: Jan 2010
Posts: 32
Default

Quote:
Originally Posted by apurvmj View Post
even with latest RB version and resized 96*96 embedded album art 'neu' theme isn't still working for me. I mean all setup works like default theme.
Kindly upload video of working theme.
thanks
Trust me, the themes are all working with the latest Rockbox build and there's nothing in my theme code that will stop your album art appearing if it's saved in one of the formats that Rockbox supports.

When you say "all setup works like default theme" that sounds like the Zip has reverted to it's default theme (but possibly with a colour scheme change) and therefore the custom theme isn't installed properly (i.e. some vital files might be missing).

Alternatively, you don't have the latest Rockbox firmware, and are still running the version from last week that was incompatible with themes showing graphical progress bars and/or volume levels.

Download the latest firmware and make absolutely sure that you have it installed. The player should say something about a new firmare and needing to reboot. Then download the required theme files and copy them back on to your Zip. I'd also recommend installing the Rockbox font pack if you haven't already.

Quote:
Originally Posted by skip252 View Post
I can't see a reason to resize your album art to 96x96. I use 500x500 baseline .jpgs on all my Rockboxed players. The size is under under 75 kb usually. At that quality they display nicely on the player and fairly well on my PC monitor. They're nice and sharp on my Fuze and e250. They do about as well as can be expected on the lower quality screen of the Clip Zip.
I've got all my artwork saved as folder.jpg at 400x400 pixels but I also have a cover.bmp file saved at 96x96 pixels as well. The folder.jpg is there so that I have a backup of the art in a decent resolution but the cover.bmp files have been optimised for the Zip.

This guarantees that the files will be under the 100Kb file size limit and they also appear slightly sharper as the Zip doesn't have to resize them on-the-fly ... it's only a subtle difference though and probably not worth the hassle for most people.

I only ended up going ths root as I was having some probblems with about 5% of my album art not appearing correctly on the Zip/Rockbox. I think it was a mixture of some of the original embedded album art being too large plus I discovered that Windows Media Player had been downloading and saving extra album art in my folders (as hidden system files) some of which was incompatible with the Zip/Rockbox.

Anyway, I went through my entire collection, re-did the album art in a consistent fashion that I knew would be compatible and optimised for the Zip/Rockbox, and it's now showing perfectly with 100% of my music collection.

Last edited by TCD1975; 02-17-2012 at 01:08 PM.
Reply With Quote

  #36  
Old 02-18-2012, 08:05 AM
apurvmj apurvmj is offline
Junior Member
 
Join Date: Dec 2011
Posts: 18
Default

this time around I did downloaded font pack and installed it.
Now its working fine.
thanks.
But I wonder what the font pack would do to it?
Reply With Quote

  #37  
Old 02-18-2012, 09:10 AM
apurvmj apurvmj is offline
Junior Member
 
Join Date: Dec 2011
Posts: 18
Default

Now all these themes are working nice, I wish the backround colour of 'stg' theme to match the crimson red, that of my red CZ and bottom band to be of silver just as to match overall colour scheme of CZ red model.
Thanks
Reply With Quote

  #38  
Old 02-18-2012, 09:28 AM
TCD1975 TCD1975 is offline
Junior Member
 
Join Date: Jan 2010
Posts: 32
Default

Quote:
Originally Posted by apurvmj View Post
this time around I did downloaded font pack and installed it.
Now its working fine.
thanks.
But I wonder what the font pack would do to it?
In the theme files you have to specify which font is used for the various bits of info on the screen. If Rockbox can't find those fonts, because the font pack hasn't been installed, it will revert to the default theme layout but update the colour scheme.

Quote:
Originally Posted by apurvmj View Post
Now all these themes are working nice, I wish the backround colour of 'stg' theme to match the crimson red, that of my red CZ and bottom band to be of silver just as to match overall colour scheme of CZ red model.
Thanks
Get yourself some image editing software and edit it yourself if you want ... I'm not doing requests.
Reply With Quote

  #39  
Old 02-19-2012, 12:26 AM
apurvmj apurvmj is offline
Junior Member
 
Join Date: Dec 2011
Posts: 18
Thumbs up

Hi TCD1975
First, during this mess and tensions I forgot to thanks and appreciate the work you have you done. It’s really awesome. ‘STG’ is mine favourite as my CZ is red in colour.
About the modifying theme background will you pls guide me what to change.
Your some guidance will help me and many other guys like me to get started.
Once again thanks and thumbsup .
Reply With Quote

  #40  
Old 02-21-2012, 10:41 AM
apurvmj apurvmj is offline
Junior Member
 
Join Date: Dec 2011
Posts: 18
Default

Hi TCD1975
I managed to change golden bottom strip into silver one by converting it to grey. So far so good but friend how to change colour of golden scrolling highlighter?
Pls guide.
Thanks.
Reply With Quote

Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT -5. The time now is 05:49 AM.