android
  #1  
Old 10-09-2010, 05:45 AM
Mog Mog is offline
Junior Member
 
Join Date: Jan 2008
Posts: 3
Help Fuze+ Album Art not displaying properly?

So I got the Sansa Fuze+ 8GB yesterday and so far it's okay but the only problem (besides a bit oversensitive touch control) I have with it is the random album art detection. By this I mean that some albums and/or songs just won't display the album art even though they are encoded/tagged/whatever using the same method as all the other songs and album art jpg's. I've updated the firmware and batch converted all the jpg's in case it was a format problem but it wasn't since it didn't change anything, so I would just like to ask am I the only one with this problem or is there a bug in the firmware?

[edit] So while retagging some files beauce of a Unicode/UTF-16 mistag I've noticed that embeding the album art into the mp3 solves the album art not displaying problem. It seems the firmware is only having problems detecting album art that is stored in a seperate file e.g. cover.jpg, AlbumArt.jpg, folder.jpg or something like that.

Last edited by Mog; 10-09-2010 at 07:22 AM. Reason: update
Reply With Quote

Advertisement [Remove Advertisement]

  #2  
Old 10-10-2010, 07:34 PM
meetooman's Avatar
meetooman meetooman is offline
Member
 
Join Date: Oct 2009
Posts: 488
Default

Quote:
Originally Posted by Mog View Post
It seems the firmware is only having problems detecting album art that is stored in a seperate file e.g. cover.jpg, AlbumArt.jpg, folder.jpg or something like that.
Embedding seems to be the fool proof way for modern devices with mp3 files. Have you test this with ogg files, as they do not support any embedding procedure ?
Reply With Quote

  #3  
Old 10-11-2010, 10:22 AM
Mog Mog is offline
Junior Member
 
Join Date: Jan 2008
Posts: 3
Default

Haven't done any testing with ogg files since I don't really have any music stored in that format but I guess it's the same as flacs that don't have the album art embedded, random. This means that hen you go into the Album view the album won't show the album art but the songs in the album will, but again, randomly, some yes some no.
Reply With Quote

  #4  
Old 10-11-2010, 10:53 AM
meetooman's Avatar
meetooman meetooman is offline
Member
 
Join Date: Oct 2009
Posts: 488
Default

So there is room for firmware improvement...
Reply With Quote

  #5  
Old 10-11-2010, 12:00 PM
lestatar's Avatar
lestatar lestatar is offline
Ultra Senior Member
 
Join Date: Dec 2009
Location: Hong Kong now, but NYC always
Posts: 4,657
Default

Mog's relatively common experiences with album art art problems [on the Fuze+] using the folder.jpg method is the singular reason why I continue to feel that embedded art is the only way to go.

I have never had any issues whatsoever on any of my AArt capable DAPs with embedded album art. Period.

The only exception to this are my Rockboxed players but that is simply because atm, RB does not support embedded art - I only need to use 1 simple utility to extract my embedded art files and I am good to go.

In any event, very glad Mog was able to sort this out. And indeed, perhaps this folder.jpg art issue will be addressed by Sandisk down the road.
__________________
DAPs:2xRBFuze8+16GB|SonyE345|ZenV+,Micro,Xtra40GBx2|RBG igabeatFX|RCAOpal
IEMs:PanaHJE900|Nuforce 700x|HippoVB|iMetal590,i490|SM PL-21|CX300|EP630,Aurvana
Guitars:IbanezS540,JS1200|Ovation
PoolCues: a bunch
A Glossary for Newbies
Reply With Quote

  #6  
Old 10-11-2010, 12:21 PM
Marvin the Martian's Avatar
Marvin the Martian Marvin the Martian is offline
Ultra Senior Member
 
Join Date: Oct 2008
Location: east central NY state
Posts: 10,602
Default

Yet with the original Fuze, the folder.jpg worked flawlessly for me, back in the day when I had my first Fuze....and that was before I knew anything about embedding. Of course, at that time, I had only tried mp3 and wma files.
__________________
iPod Touch 5G 32GB, Touch 4G 32GB, Clip Sport 8GB. Rockbox-> Clip Zip 4GB, iPod Nano 2G 4GB, iPod 5.5G 80GB
2012 Nexus 7 32GB, Asus MeMoPad 8 16+64GB, LG Optimus G Pro, Nokia Lumia 900 and Lumia 520
Reply With Quote

  #7  
Old 10-11-2010, 12:30 PM
lestatar's Avatar
lestatar lestatar is offline
Ultra Senior Member
 
Join Date: Dec 2009
Location: Hong Kong now, but NYC always
Posts: 4,657
Default

True, Marv! My point only being that embedded art has been fully supported since the first AArt capable DAPs, immediately, right out of the boxes.

If I am not mistaken, embedded art support may actually have predated the whole folder.jpg organizational method.
__________________
DAPs:2xRBFuze8+16GB|SonyE345|ZenV+,Micro,Xtra40GBx2|RBG igabeatFX|RCAOpal
IEMs:PanaHJE900|Nuforce 700x|HippoVB|iMetal590,i490|SM PL-21|CX300|EP630,Aurvana
Guitars:IbanezS540,JS1200|Ovation
PoolCues: a bunch
A Glossary for Newbies
Reply With Quote

  #8  
Old 12-20-2010, 10:07 AM
Fonce Falooda Fonce Falooda is offline
Junior Member
 
Join Date: Dec 2010
Posts: 2
Default

I can't figure it out. I embedded all my album art in iTunes, dragged the folders from my iTunes Library onto my Fuze+, but only half of them are showing up. Got LOADS of the trippy op-art swatches.

Then I pulled an album back onto my computer, opened it up in "mp3tag" and can see the cover! So it's there, but my Fuze+ refuzes to see it.

I've tried reducing the image's file size, and some other esoteric stuff, but can't get it to work. Shouldn't really be this hard. (And forgive all the iTunes references. Almost ready to switch to Songbird.)
Reply With Quote

  #9  
Old 12-20-2010, 10:13 AM
dfkt's Avatar
dfkt dfkt is offline
Moderator
 
Join Date: May 2006
Location: Vienna, Austria
Posts: 15,330
Default

Make sure the album art is baseline JPEG - most players can't read progressive JPEGs.
__________________
Please don't PM me with questions that can be answered in a forum thread. Don't be an idiot.
My Gear and Reviews | My RMAA Tests | IRC: #anythingbutipod on Freenode | Last.fm | Album Art Exchange | Rockbox | Replaygain
Reply With Quote

  #10  
Old 12-20-2010, 10:25 AM
Fonce Falooda Fonce Falooda is offline
Junior Member
 
Join Date: Dec 2010
Posts: 2
Default

You are good. That was it! Thanks so much!
Reply With Quote

  #11  
Old 01-14-2011, 08:23 PM
Hiddemen Hiddemen is offline
Junior Member
 
Join Date: Dec 2010
Posts: 3
Default Pixels per inch

Hi,

I also ran into a strange problem. New art that I created at 72 pixels per inch would not display. If I set it for 120 pixels per inch it worked flawlessly
Reply With Quote

  #12  
Old 01-31-2011, 11:17 PM
monkeydonkey monkeydonkey is offline
Junior Member
 
Join Date: Jan 2011
Posts: 1
Default

Hey guys I got the image display working on my fuze+. First you gotta download the album art downloader, http://sourceforge.net/projects/album-art/ , once you have it on your pc, play around with the program. Its pretty simple program and its quick. To get your image fit on your fuze+ display, make sure that the .jpg image dimension is atleast 500 x 500. This should do it.

It works in mine....now I'm happy!!!!
Reply With Quote

  #13  
Old 03-19-2011, 08:27 AM
9mmtylenol's Avatar
9mmtylenol 9mmtylenol is offline
Junior Member
 
Join Date: Mar 2011
Location: Georgia, United States
Posts: 5
Default

Hey does anyone know the best resolution to put album art on the fuze+, I had done it with my PSP at 300x300 and it does take some time to load the images embedded to the mp3. I want a match perfect image, not small to distort the image and not to beg to take up time on loading.
Reply With Quote

  #14  
Old 03-19-2011, 09:36 AM
lestatar's Avatar
lestatar lestatar is offline
Ultra Senior Member
 
Join Date: Dec 2009
Location: Hong Kong now, but NYC always
Posts: 4,657
Default

^ Welcome to ABi!

From the Fuze+ manual: http://www.sandisk.com/microsites/sa...7121408057.pdf

2.1. Features
• Vibrant 2.4” QVGA LCD screen (320x240) for brilliant views of your videos, photos,
and album art.


Just to give you an idea, all my art is embedded and I use at least 500x500 but file sizes never more than 75-100k - this goes for my entire music library. And most important, all BASELINE jpgs, not progressive. No album art capable player I have ever owned has ever had a problem.

AFAIK, artwork usually gets resized on the fly on most DAPs that support artwork, embedded or otherwise.

Not sure you need to have a specific dpi for the Fuze+? On my 2 Fuzes, the stock firmware was just fine with my embedded art as high as 600x600. I would think this would still be the case with the Fuze+.

There's also this from the manual:
Native photo file support of JPG and BMP file formats. Additional file formats
including TIFF, GIF, PCX, TGA, and PNG can be added to the player easily using the
optional free downloadable Sansa Media Converter software available via the Sansa
Updater. See www.sandisk.com/smc for more information. This application can also
be used to optimize viewing of native file type on the Sansa Fuze+ screen (i.e.,
aspect ratios and resolution).


Though I personally never install stuff like this from DAP makers unless absolutely essential. I really don't think it's necessary.
__________________
DAPs:2xRBFuze8+16GB|SonyE345|ZenV+,Micro,Xtra40GBx2|RBG igabeatFX|RCAOpal
IEMs:PanaHJE900|Nuforce 700x|HippoVB|iMetal590,i490|SM PL-21|CX300|EP630,Aurvana
Guitars:IbanezS540,JS1200|Ovation
PoolCues: a bunch
A Glossary for Newbies

Last edited by lestatar; 03-19-2011 at 09:41 AM.
Reply With Quote

  #15  
Old 03-22-2011, 08:23 AM
Mog Mog is offline
Junior Member
 
Join Date: Jan 2008
Posts: 3
Default

The Sansa Updater is junk software, tried it and no matter what I tried to do it kept endlessly updating

Anyways, I tried progressive and baseline jpgs, all sizes, embedded and withing the folder in it's own seperate jpg, at best album art detection and display is completely random.

Also recently I've been getting more and more hang ups and crashes with my Fuze+ so I'm already in search for another more stable and reliable portable media player that actually functions properly.

I must say I didnt' expect SanDisk could disappoint me this much. One would at least expect they would hurry with putting out firmware updates but I'm guessing they too realised they blew it with the Fuze+.
Reply With Quote

  #16  
Old 03-22-2011, 08:29 AM
lestatar's Avatar
lestatar lestatar is offline
Ultra Senior Member
 
Join Date: Dec 2009
Location: Hong Kong now, but NYC always
Posts: 4,657
Default

^ This sucks...sorry to hear that... Especially with Sandisk's great track record on the Fuze and the Clip/+...

EDIT: I assume you already updated to the latest Fuze+ FW?
__________________
DAPs:2xRBFuze8+16GB|SonyE345|ZenV+,Micro,Xtra40GBx2|RBG igabeatFX|RCAOpal
IEMs:PanaHJE900|Nuforce 700x|HippoVB|iMetal590,i490|SM PL-21|CX300|EP630,Aurvana
Guitars:IbanezS540,JS1200|Ovation
PoolCues: a bunch
A Glossary for Newbies

Last edited by lestatar; 03-22-2011 at 08:56 AM.
Reply With Quote

  #17  
Old 03-22-2011, 01:30 PM
FreeZ5's Avatar
FreeZ5 FreeZ5 is offline
Ultra Senior Member
 
Join Date: Nov 2006
Location: Niagara Region, Ontario, Canada
Posts: 2,504
Default

Quote:
Originally Posted by lestatar View Post
I assume you already updated to the latest Fuze+ FW?
Also, assume that you have learned how to do a manual firmware update.

Steve

Last edited by FreeZ5; 09-14-2012 at 02:45 PM.
Reply With Quote

  #18  
Old 04-03-2011, 03:21 PM
9mmtylenol's Avatar
9mmtylenol 9mmtylenol is offline
Junior Member
 
Join Date: Mar 2011
Location: Georgia, United States
Posts: 5
Default Finally

So, I just got mu fuze+ 16gb and it's awesome in my opinion, and I found out that 300x300 works the best on the player, not too much not to small. But I transfered all my music on the player and a hand full of my complete albums do not show, and these are entire discographies that a mojority of the albums do show the artwork in full while embedded without placing a jpeg in the designated folder. I tried re-taging and while using new jpeg's, instead of the old, some of the albums started showing up. Though there is still 10+ that won't show the art and I also see white lines bordering the album art while viewing it in the album select pane. Any thing that I could do to solve this?

Last edited by 9mmtylenol; 04-03-2011 at 03:27 PM. Reason: updated information
Reply With Quote

  #19  
Old 04-04-2011, 05:51 AM
megafan2000 megafan2000 is offline
Junior Member
 
Join Date: Jan 2011
Posts: 9
Default

Quote:
Originally Posted by 9mmtylenol View Post
So, I just got mu fuze+ 16gb and it's awesome in my opinion, and I found out that 300x300 works the best on the player, not too much not to small. But I transfered all my music on the player and a hand full of my complete albums do not show, and these are entire discographies that a mojority of the albums do show the artwork in full while embedded without placing a jpeg in the designated folder. I tried re-taging and while using new jpeg's, instead of the old, some of the albums started showing up. Though there is still 10+ that won't show the art and I also see white lines bordering the album art while viewing it in the album select pane. Any thing that I could do to solve this?
when I upgraded to Fuze+ I found if you see the white lines then it's probably because the album art is uneven - if it's 299x300 then it will white line. I find 300x300 works best as well so that's what i use now as all my embedded art. so I went through each album to make sure each image was 300x300 and that's my standard.
Reply With Quote

  #20  
Old 09-14-2012, 12:32 PM
psychoTR2 psychoTR2 is offline
Junior Member
 
Join Date: Jul 2011
Posts: 9
Default

I found that the Sansa Fuze+ won't display any album art from WMA files, whether it's embedded, or folder.jpg, I tried both at the same time. I've converted every album I had in WMA (stuff I've had since my first MP3 player) to MP3 and Album Art displayed without a hitch. I'm using the newest version of the Fuze+ firmware.
Reply With Quote

Reply

Tags
album art, display, fuze+, problem

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT -5. The time now is 01:53 PM.