android
  #1  
Old 10-13-2012, 12:40 PM
TheKryptonite TheKryptonite is offline
Junior Member
 
Join Date: Sep 2012
Posts: 35
Default Bad SD card?

I have a 32 SB Sandisk SD card, and I've noticed that it works when it's blank, but when I put files on it, it becomes corrupt/damaged, the next day. Is there a reason for this? I don't want to buy another SD card for the same thing to happen (I guess I shouldn't have "done" anything to the SD card slot).

Last edited by TheKryptonite; 10-13-2012 at 12:45 PM.
Reply With Quote

Advertisement [Remove Advertisement]

  #2  
Old 10-13-2012, 01:57 PM
FreeZ5's Avatar
FreeZ5 FreeZ5 is offline
Ultra Senior Member
 
Join Date: Nov 2006
Location: Niagara Region, Ontario, Canada
Posts: 2,512
Default

Perhaps you can explain what "done" something to the SD card slot means. Does the card work fine in another device like a PC?

Where did you get the SDcard? Hopefully not eBay (home of the fakes). Have you tested the card with a program like H2TESTW? If you're having problems with a card, then it's the first thing to do, IMO.

Steve
__________________
Everybody should own at least one Sansa Clip family player. Except maybe the Sport.
Reply With Quote

  #3  
Old 10-13-2012, 02:35 PM
TheKryptonite TheKryptonite is offline
Junior Member
 
Join Date: Sep 2012
Posts: 35
Default

Stuck a toothpick in the SD slot and lifted it up. I heard it would "solve" the SD card reading problems or whatever -_- I got it from Amazon. It works, but only if it isn't already damaged; otherwise, I'll end up having to format it (on the PC).
Reply With Quote

  #4  
Old 10-13-2012, 02:41 PM
Marvin the Martian's Avatar
Marvin the Martian Marvin the Martian is offline
Ultra Senior Member
 
Join Date: Oct 2008
Location: east central NY state
Posts: 10,602
Default

Quote:
Originally Posted by TheKryptonite View Post
Stuck a toothpick in the SD slot and lifted it up. I heard it would "solve" the SD card reading problems or whatever -_- I got it from Amazon. It works, but only if it isn't already damaged; otherwise, I'll end up having to format it (on the PC).
That was probably not a good idea.
__________________
iPod Touch 5G 32GB, Touch 4G 32GB, Clip Sport 8GB. Rockbox-> Clip Zip 4GB, iPod Nano 2G 4GB, iPod 5.5G 80GB
2012 Nexus 7 32GB, Asus MeMoPad 8 16+64GB, LG Optimus G Pro, Nokia Lumia 900 and Lumia 520
Reply With Quote

  #5  
Old 10-13-2012, 05:23 PM
TheKryptonite TheKryptonite is offline
Junior Member
 
Join Date: Sep 2012
Posts: 35
Default

Even before then it'd become corrupt.
Reply With Quote

  #6  
Old 10-14-2012, 06:13 PM
Yaph Yaph is offline
Junior Member
 
Join Date: Nov 2011
Location: Montreal, QC, Canada
Posts: 20
Default

Try to do a full test with H2TestW.

And a physically altering you card reader IS A *BAD* idea; just don't: chances are it is your SD card that is defective, and even if it is your card reader, unless something is stuck inside, a toothpick wont help.

[EDIT]
You should read this -> http://reviews.ebay.co.uk/Detecting-...00000013353853
Reply With Quote

  #7  
Old 10-15-2012, 04:22 AM
TheKryptonite TheKryptonite is offline
Junior Member
 
Join Date: Sep 2012
Posts: 35
Default

The test finished without errors.
Reply With Quote

  #8  
Old 10-18-2012, 01:26 AM
Daniel644 Daniel644 is offline
Member
 
Join Date: Nov 2011
Posts: 475
Default

in the last few days my player has on several occasions now either not restart my music on headphone plug in or stops after a few seconds, and this last time I was able to get the screen on quick enough to see it say "Damaged SD card" but it goes away and the media scanner runs and my files play fine, is this like your issue?
__________________
Galaxy S 4.0 Wifi (USA)
Running STeVEs custom Kernel
and Klin's Klassic 2.3.6 ROM for Galaxy Player 4.0 USA
Reply With Quote

  #9  
Old 10-18-2012, 12:55 PM
TheKryptonite TheKryptonite is offline
Junior Member
 
Join Date: Sep 2012
Posts: 35
Default

Quote:
Originally Posted by Daniel644 View Post
see it say "Damaged SD card" but it goes away and the media scanner runs and my files play fine, is this like your issue?
The message stays up, and the files that isn't on the SD card play, obviously. Tried another rom (2.3.6) and the same thing happens. I guess I'll have to try another card.

Edit: Noticed that it's a refurbished SGP from Nuko. Don't know if it's why it's happening, but it' pretty damn annoying.

Last edited by TheKryptonite; 10-18-2012 at 08:06 PM.
Reply With Quote

  #10  
Old 10-19-2012, 12:27 PM
TheKryptonite TheKryptonite is offline
Junior Member
 
Join Date: Sep 2012
Posts: 35
Default

I just downloaded Chips rom, and everything is going good for now. Not sure if it will "last," however.

Edit: Same message. Time for a new SD card, I guess.

Last edited by TheKryptonite; 10-19-2012 at 02:52 PM.
Reply With Quote

  #11  
Old 11-04-2012, 10:26 PM
Daniel644 Daniel644 is offline
Member
 
Join Date: Nov 2011
Posts: 475
Default

well looks like I might of solved my issue, been 2 days without issue, what I did was put a piece of tape on my SD card to "thicken" it up so the contacts make a better more solid connection. Maybe this may help others.
__________________
Galaxy S 4.0 Wifi (USA)
Running STeVEs custom Kernel
and Klin's Klassic 2.3.6 ROM for Galaxy Player 4.0 USA
Reply With Quote

Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT -5. The time now is 01:38 AM.