android
  #1  
Old 11-16-2012, 01:22 PM
Corwin72 Corwin72 is offline
Junior Member
 
Join Date: Nov 2012
Posts: 3
Default Support help> Galaxy 5.0 not powering up.

Hi,
I have had a refurbished 5.0 since June. Today I was listening to some music and I plugged the device in to my computer to load some new music. The screen went black and I can not restart the media player. The device gets really hot and I have put it in the refrigerator to keep the temperature down.
Do I have a dead device?
Thanks for your help in advance.
Reply With Quote

Advertisement [Remove Advertisement]

  #2  
Old 11-16-2012, 01:37 PM
Corwin72 Corwin72 is offline
Junior Member
 
Join Date: Nov 2012
Posts: 3
Default

Update!
it got cool and I plugged it in to a different location and the battery symbol came up with a green sliver on the right side.
Things are looking up!
Reply With Quote

  #3  
Old 11-16-2012, 07:18 PM
brosko brosko is offline
Member
 
Join Date: May 2012
Location: Long Island, New York
Posts: 220
Default

I would imagine something is not right with what you described. I would not be to confident that the device is "fixed". We'll hope for the best though.
Reply With Quote

  #4  
Old 11-16-2012, 11:24 PM
Corwin72 Corwin72 is offline
Junior Member
 
Join Date: Nov 2012
Posts: 3
Default

I charged it until 100%. We will see what it is like tomorrow.
Reply With Quote

  #5  
Old 11-17-2012, 04:00 PM
brosko brosko is offline
Member
 
Join Date: May 2012
Location: Long Island, New York
Posts: 220
Default

Let us know what happens
Reply With Quote

Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT -5. The time now is 12:30 PM.