android
  #1  
Old 12-16-2013, 08:17 PM
KennyRocks KennyRocks is offline
Junior Member
 
Join Date: Dec 2013
Posts: 8
Default H320-ROCKBOX ERROR (Result-4)

I dropped my H320 and now it wont load ROCKBOX
I can boot to the Iriver Firmware and play music, so the HDD works..
The Drive is recognized by my PC, I formatted the HDD reinstalled ROCKBOX
But still yet it crashes with an error of Result -4 and turns off.

Does anyone have any ideas ?

I thought it was a HDD problem but it works fine and the iriver os plays music fine.

I'm confused.
Reply With Quote

Advertisement [Remove Advertisement]

  #2  
Old 12-17-2013, 01:28 PM
jumbuck jumbuck is offline
Junior Member
 
Join Date: Feb 2010
Location: Northern N.S.W Australia
Posts: 48
Default

Hi KennyRocks and welcome.
It would appear that you have damaged your hard drive.
You could try running windows check disc and see if it'll find and repair any damaged sectors on your drive. (right click your player in My Computer and select tools then error checking) but I'd probably look at replacing the drive.
Directions for disassembly are here http://www.divshare.com/download/24158328-858 and a list of compatible drives are here http://www.anythingbutipod.com/forum...ad.php?t=70395
Heres a couple of links on your problem which may worth having a read of they are for h120s which have a lot of the same components as the h320
http://forums.rockbox.org/index.php?topic=23798.0
http://anythingbutipod.com/forum/showthread.php?t=52173
And a list of the error codes http://www.rockbox.org/wiki/IpodBootloaderErrorCodes it's the ipod page but evidently the same codes apply for the iriver.

Last edited by jumbuck; 12-17-2013 at 01:33 PM. Reason: bad spellun
Reply With Quote

  #3  
Old 12-17-2013, 01:56 PM
KennyRocks KennyRocks is offline
Junior Member
 
Join Date: Dec 2013
Posts: 8
Default

Thanks for taking the time to reply JumBuck.. It has been frustrating trying to get information on my problem. I shall order a new HDD and see if that helps the problem. Thanks for the links

I shall update with news in the future.
Reply With Quote

  #4  
Old 12-25-2013, 05:38 AM
KennyRocks KennyRocks is offline
Junior Member
 
Join Date: Dec 2013
Posts: 8
Default

Christmas Day morning and I am replacing the HDD..
I am getting an error

ATA error: -11
Insert USB cable and press
a button

Now when I install the cable I connect to my laptop I installed RockBox and it worked.. But when I disconnect my player, turn off then turn on I always get this error..

Any ideas??

Reply With Quote

  #5  
Old 12-25-2013, 05:42 AM
KennyRocks KennyRocks is offline
Junior Member
 
Join Date: Dec 2013
Posts: 8
Default

I have made sure the HDD is connected and was very gentle dismantling the player.
Reply With Quote

  #6  
Old 12-27-2013, 01:48 PM
jumbuck jumbuck is offline
Junior Member
 
Join Date: Feb 2010
Location: Northern N.S.W Australia
Posts: 48
Default

Hi Kenny , sorry for the late reply but Ive been out of town for a few days.
The ATA 11 error is normally a connection problem between the hard drive and the player or a hard drive problem.
Try reinstalling the old drive and see if the ATA 11 error is still there. If it isn't then it'll point towards the new drive being faulty.
Also check the ribbon cable hasn't become dislodged from the mother board , it's been a long while since I've had a h320 apart (I own h120/40's) but from memory the ribbon can become dislodged from the mother board. If it is then ,as fa as I can remember, You need to gently flip up the brown strip where the ribbon cable goes onto the mother board to release it the push the ribbon in and push the clip down. Be gentle as the ribbon can be easily damaged.
Reply With Quote

  #7  
Old 01-08-2014, 05:21 PM
KennyRocks KennyRocks is offline
Junior Member
 
Join Date: Dec 2013
Posts: 8
Default

OKay update time.. I have bought a replacement HDD from Ebay..
I installed this and when I turn the player on I get the message 'CHECK HDD CONNECTION' This HDD should be fine. its brand new and came wrapped in a box full of bubble wrap so there is no way it was damaged in transit.
I have checked the HDD connection and everything seems fine.
So confusing..???
Reply With Quote

  #8  
Old 01-08-2014, 05:32 PM
KennyRocks KennyRocks is offline
Junior Member
 
Join Date: Dec 2013
Posts: 8
Default

This is so weird.. I can see the HDD on my laptop and have installed Rockbox..but am getting an error on Rockbox startup
ATA error: -32
Insert USB cable and press a button ??

Booting in Iriver OS I still get the 'Check HDD Connection' but i can feel the HDD spinning.. so I presume it is connected properly as I have copied some music across from my laptop... WTF is going on ??
Reply With Quote

Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT -5. The time now is 12:45 PM.